uMap

updated to version 1.6.1

Menci Software - Copyright © 2013

WebSite: http://www.menci.com - E-Mail: info@menci.com


About uMap

uMap is the Menci Software technology used to get high resolution point clouds from digital images.
Providing strips with a good overlap (at least 60% between them) and distance/altitude as costant as possible it is possible to create through automatic steps, a 3D model for analysis and documentation.

EVO (terrestrial photogrammetry) uFly (aerial photogrammetry)

The 3D models are suitable for the most common elaborations in the Photogrammetric field, among them: DEM, orthophoto, orthomosaic, profiles, contours, georeferencing and so on.

Features

  • High number of importable images
  • Camera passport extractable
  • Management of terrestrial (EVO) and aerial (uFly) images
  • Images can be processed by using GPU technology
  • Georeferencing with control points (GCP)
  • Automatic Bundle among images
  • Possibility to scale the model
  • Custom resolution step for the 3D model
  • Viewing of the point cloud
  • Viewing of the camera position and related images


Snapping Rules

  • Never perform a sequence of shots from the same position. Always perform a displacement between a photo and the other in order to provide a suitable shooting base which takes into account the distance between camera and subject. Within a certain tollerance and according to the optic used, the photogrammetric rule can be considered valid and the distance between two following shots should be 1/10 of the distance between subject and camera.
  • The images must be taken as frontal as possible to the surface. Any non-perpendicular image can be pulled out during the reconstruction phase.
  • The subject must show a discontinuos distribution of color (monochrome subjects tend to vanish during the 3D reconstruction).

  • When it is not possible change the shooting distance and the camera must be tilted with respect to the surface, we recommend to snap with an angle lesser than 20° (towards the top or bottom), expecially if you don't have control points gained through total station.
  • Avoid backgrounds which have nothing in common with the subject. When it is possible insert a neutral background (white or black) which can emphasize the subject.
  • Pictures from great distances are not recommended (farther than 10-15 m).
  • Do not consider images with big relative distances in the same session: the software can take into account the points of a close subject or those of a far subject as a mistake and discard them during the processing.
  • The overlap (vertical/horizzontal) between images should be at least 50%, 60% it is even better, images with a higher overlap tend to be redundant.

  • When turning around a subject (even though with an angle lesser than 360°), try to avoid snapping pictures with a rotation angle too wide because they should have a wider overlap than usual, this should be done especially when turning around a corner. Try to keep the same distance between you and the subject in order to avoid scale effects.
  • It is possible to snap pictures both horizontal and vertical, but it is forbidden to mix them togheter.
  • Avoid strong light variation (intensity and direction) between a snap and the other. we recommend to use soft and uniform lights. Usually a perpendicular illumination makes the shade as even as the surface, for this reason we recommend a lateral illumination in order to emphasize the roughness.
  • To optimize the focus of each element on the taken surface it is recommended to set the camera with a high f number (diaphragm for the most closed, values higher than 10). When the diaphragm tends to close the depth of field tends to increase. The sharpness of an image also depends on the distance of the subject: for this reason the depth of field decreases when the subject gets closer.
  • It can be tricky when a surface presents regular patterns along the horizontal or vertical axis of the frame. A method to bypass the issue is to slighty tilt the bar in order to allow the algorithm a better orientation when building the 3D model.


Camera passport

How to take images for uMap calibration

uMap calibration create a camera passport usable for uMap 3D model production. Every camera and lens combination must have its own camera passport in order to elaborate images. If you are using a zoom lens you will need a different passport for every focal length position. Passport features (e.g. distortion coefficients) cannot be exported outside uMap.

· Typical lens focal length range is from 16 up to 50 mm (fixed lens are preferable).

· Take at least 8 pictures with the camera set to full resolution (not raw), highest quality (images must be formatted like a work datasets).

· The images must have at least 50-60% of horizontal overlap.

· To strengthen the calibration take a second image strip shifting the elevation up or low. Images must have a 50-60% of vertical overlap.

· Each shooting position should be distant from the previous one about 1/10 of the distance between the camera and the surface (that is the photogrammetric standard baseline).

· If the camera allows it, do focus on the first shoot and then lock it. Don't use blurred, moving or over/under exposed images. Good camera settings are ISO 200, aperture f/8 or 1/125 sec. exposure time.

Be at work distance (the distance should be similar to work datasets) and keep that distance for all calibration shots.

Sample (first 4 pictures)

1 2 3 4

  • Select a subject with a chromatically irregular surface (e.g. no painted walls).

  • Avoid surfaces with repetitive patterns.

  • Avoid transparent / shiny surfaces.

  • Take frontal shots (no tilted or rotating images).

  • Avoid surfaces with complex scene (no sky inside, no significant deep differences)


Main Interface

When uMap starts the following interface will be shown.

By clicking the icon “uMap” it is possible to set up a new project, open an existing one, save the modifications made during the processing, extract the camera passport or test the GPU.

NOTE: the GPU test is optional and it is useful to see whether the GPU is available or not within the graphics card in your computer. However even though there are no GPU available, the software's capability will not be affected but the running process will be a little longer.

The main interface can be splitted in to three sections:

- Toolbar

- Dataset

- CAD enviroment

Toolbar: here you can find all the commands and options to set up the 3D view and customizing the graphics interface.

Dataset: the uploaded images are shown in this section. During the processing steps on the right side of the image a yellow and then green strip are shown, the yellow one indicates that the image has been tied properly and unlike the previous the green one indicates that the following image has been used to build the 3D model.

If you want to get rid of one of your image you can click the right mouse button and select exclude image from the processing.

CAD environment: here you can check the results got from the bundle (point cloud and camera position) and the 3D model.


Adding images and Bundle

Adding Images and Bundle Process

In order to set up a new project the following icon "New" [image] must be clicked, otherwise you can click the icon "uMap" and then select"New". A new window will be open, here you can specify the name and the destination of your new project (eg. C:\....).

To set up a project the user must type a name (Project Name field).

The camera passport needs to be selected, it has to be the same passport of the camera which you have used during the snapping phase, if you don't have a suitable camera passaport you can extract it by following the steps listed in the camera passaport section of this tutorial. camera passport

If you want to open a previous project, you have to click the "Open" key [image] .

In order to upload the images click on "Add Images" [image] .

When all the images have been uploaded these will be shown in the Dataset.

The next step is to start a generic recostruction in order to tie all the images among them, this can be done by clicking the key "Do Bundle" [image] .

uMap allows to add images to the process even later, but if you want to rebuild the whole model you need to start the bundle process again.

At the end of the bundle procedure, each image that has been tied will be marked by a yellow strip on its right side. If the yellow strip is missing that image will not be tied with others images, in this case the software didn't succeed during the bundle process. Check if the images have been taken according to theshooting rules.


GCP collimation

In order to georeference your model and to allow it to get the right scale it is possible to upload some control points (GCP), to do so you need to click the "GCP" button .

A new window will be open, here you can import the file.txt with your control points by clicking on "Add Points". Once they are uploaded it is necessary to collimate each point on each image where it is included.

To import the file conteining the GCP click on "Browse" [image] .

Through this interface it is possible to define the import procedure of the coordinates listed in a txt file. You need to specify how this file has been compiled and perhaps change the order of its data.

IMPORTANT!! The fonts used as comments or separators are editable. At each modify of these fonts a change will be displayed for each of these fields, ID, X, Y e Z. Once a good formatting has been found it is possible to import the data.

It is possible to upload a few GCP or the whole list by clicking on "Select All" [image].

To begin the collimation click on the first point you want to.

Select an image where a GCP is on, to make a good collimation you have to put it in the same position where it has been taken (you need a monograph to check the real position of this point). To add a collimation use Shift+click.

Once it has been collimated a little green cross will appear.

Scroll all the images and make you sure that the collimation is acceptable.

Repeat the procedure for all the points.

At this point click on "Evaluate" to verify that residual errors have a suitable displacement, otherwise you need to repeat the collimation for those that have high residuals.

Eventually click"Apply to Images", then "OK".

This operation is not compulsory to build the 3D model, but it can be necessary if you want to use it to provide metric informations.


Scale Model

If you don't have any ground control point (GCP) it is possible to use the scale function in order to scale the model to its real dimension.

Especially it is possible to reach this target by using two different paths.

The first one consists in taking the measure of a bar directly on to the field, then this distance will be collimated on the taken pictures.

It is a step that has many points in common with the GCP procedure but unlike that, this procedure needs just to know the distance between two point measured directly on to the field.

Once you have collimated these two points you have to press the evaluate key to make start the processing.

The second procedure can be achieved when the length of the pole where the camera is mounted is known.

In this case you need to pick a point on the bundle model where the pole was put on, then insert the pole height and run the processing.


3D Model

Building 3D Model

In order to get the point cloud we need to click on the button "Run Reconstruction" [image].

A window will be shown were it is possible to set the reconstruction step.

NOTE: the GSD value it is just an indicative estimate based on the collimation of the GCP or depending to the camera passport. This value depends on the snapping condition and especially on the costancy of the distance from which these have been taken. snapping rules

A higher accuracy level value means that images resolution will be kept during the 3D reconstruction process, however the standard value of 2 is usually the best deal.

At the end of the process in the CAD window will be shown the result.

As far as concern the viewing and setting option by clicking the "Bundle Model" [image] and/or "Camera Position" [image] it is possible enable or unable the viewing of the bundle or of the camera positions.

To examime a specific frame you have to double click on the related camera position or on the thumbnail.

within the section "3D Present View" [image] a list of keys can be used to modify the orientation and the viewing of the 3D model.

Otherwise in the section "Windows" [image] it is possible to find the viewing options for the main interface.

Through the bar "Point Size" [image] it is possible to range the points size belonging to the point cloud.

Once the reconstruction process is over, your point cloud can be exported to several file formats:

VTP, PLY, OBJ, VRML and ASCII format are currently supported.


Aerial Photogrammetry

Umap can even be used for aerial pictures, by rebuilding the geographic informations and the angles refered to the camera position.

When a set of picture has been taken from a flying device (eg. drone) but for any reason the inertial and gps data can not be recorded during the survey (eg. the images have been snapped in a closed environment or if they have been taken outdoor the GPS signal gets lost), Umap can gain back these informations.

Basically once you have completed the Bundle procedure a file containing all the informations such as geographic informations (x, y, z) or angle informations (omega, phi, kappa) will be developed; this file can be used for further processing and especially to geotag the images taken from the aircraft.

The file.eo is usually stored in the folder "bundle" which is contained in the project folder, this file is nothing but a text file containing all the information listed below.

This file can then be used with other software such as APS in order to build DTM, orthophoto and DSM.


Requirements

System requirements

  • Operating System: Windows XP / Vista / 7 / 8
  • uMap is optimized for Intel processors
  • RAM: Minimum 1 GB (recommended: 4 GB)
  • Video card: nVidia models (ATI video cards are not supported in full, computation time increases considerably)
  • Minimum screen resolution: 1024x768 pixel


CREDITS

Luca Menci

Francesca Ceccaroni

Daniele Bianchini

Claudio Tortorelli

Debora Caldarelli

Marco Casella

Web Site: http://www.menci.com

Menci Software Srl
Loc Tregozzano, 87
52100 Arezzo - ITALY

E-Mail: info@menci.com